HDOJ 1004题 Let the Balloon Rise Strcmp()函数 - 谙忆-人生之旅

谙忆-人生之旅

学不止步,梦不停歇-陈浩翔

HDOJ 1004题 Let the Balloon Rise Strcmp()函数

 2015年08月21日

Problem Description Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest i


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.


Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.


Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.


Sample Input
5 green red blue red red 3 pink orange pink 0
Sample Output
red pink
代码:
#include <iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
using namespace std;

int main()
{
    int n,i,j,s=1,b[1010],f[1010];
    char a[1010][20];
    while(~scanf("%d",&n)&&n)
    {
        memset(b,0,sizeof(b));
        for(i=0; i<n; i++)
        {
            scanf("%s",a[i]);
        }
        for(i=0; i<n; i++)
        {
            f[i]=1;
            for(j=i+1; j<n; j++)
            {
                if(b[j]==0)
                {

                    if(strcmp(a[i],a[j])==0)//这里我不知道为什么用a[i]==a[j]就不可以,求大神评论解释一下,谢谢了
                    {
                        b[j]=1;
                        f[i]=f[i]+1;
                    }
                }
            }
        }
        int s=0;
        for(i=0; i<n; i++)
        {
            if(f[s]<=f[i])
            {
                s=i;
            }
        }
        printf("%s\n",a[s]);
    }
    return 0;
}


本文章由[谙忆]编写, 所有权利保留。 欢迎转载,分享是进步的源泉。

转载请注明出处:http://chenhaoxiang.cn

本文源自人生之旅_谙忆的博客