HDOJ 1013题Digital Roots 大数,9余数定理 - 谙忆-人生之旅

谙忆-人生之旅

学不止步,梦不停歇-陈浩翔

HDOJ 1013题Digital Roots 大数,9余数定理

 2015年08月21日

Problem Description The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resultin


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.


Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.


Output
For each integer in the input, output its digital root on a separate line of the output.


Sample Input
24 39 0

Sample Output
6 3


一个数对九取余,得到的数称之为九余数;
一个数的九余数等于它的各个数位上的数之和的九余数!


题目大意:

 给定一个正整数,根据一定的规则求出该数的数根,其规则如下:

        例如给定 数字 24,将24的各个位上的数字分离,分别得到数字 和 4,而2+4=6

        因为 6 < 10,所以就认为6是数字24数根

        而对于数字 39  将39的各个位上的数字分离,分别得到数字 和 9,而3+9=12,12>10

       所以依据规则再对 12 进行相应的运算,最后得到数字3,而3<10,所以就认为3是数字39数根

       

              通过运算可以发现任何一个数的数根都是一个取值范围在 1 ~ 9之间的正整数,

     且任何一个正整数都只有唯一的一个数根与其相对应。

              题目要求数字 n^n 数根

解题思路:

九余数定理

一个数对九取余后的结果称为九余数。

一个数的各位数字之和想加后得到的<10的数字称为这个数的九余数(如果相加结果大于9,则继续各位相加)

代码如下:
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
int main()
{
    char a[1010];
    int i,j,s,l;
    while(~scanf("%s",&a)&&a[0]!='0')
    {
        l=strlen(a);
        s=0;
        for(i=0;i<l;i++)
        {
            s=s+a[i]-'0';
        }
        s=s%9;
        if(s==0)
            s=9;
        printf("%d\n",s);
    }
    return 0;
}


一个数对九取余,得到的数称之为九余数;
一个数的九余数等于它的各个数位上的数之和的九余数!

本文章由[谙忆]编写, 所有权利保留。 欢迎转载,分享是进步的源泉。

转载请注明出处:http://chenhaoxiang.cn

本文源自人生之旅_谙忆的博客