HDOJ1021题 Fibonacci Again 应用求模公式 - 谙忆-人生之旅

谙忆-人生之旅

学不止步,梦不停歇-陈浩翔

HDOJ1021题 Fibonacci Again 应用求模公式

 2015年08月21日

Problem Description There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).Input Input consists of a sequence of lines, each containing an integer n. (n < 1,0 求模公式


Problem Description There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output Print the word “yes” if 3 divide evenly into F(n).

Print the word “no” if not.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
Sample Input
0
1
2
3
4
5
 

Sample Output
no
no
yes
no
no
no
1
2
3
4
5
6
应用求模公式
        (1) (a + b) % p = (a % p + b % p) % p 
        (2) (a - b) % p = (a % p - b % p) % p 
        (3) (a * b) % p = (a % p * b % p) % p 
        (4)  a ^ b % p = ((a % p)^b) % p 
        如果不用的话会溢出。

代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
using namespace std;

int main()
{
    int a[1000001],i,j,s;
    a[0]=7;a[1]=11;
    for(i=2;i<1000001;i++)
    {
        a[i]=(a[i-1]%3+a[i-2]%3)%3;//只写最后那个%3也可以
    }
    while(~scanf("%d",&s))
    {
        if(a[s]%3==0)
            printf("yes\n");
        else
            printf("no\n");
    }
    return 0;
}

本文章由[谙忆]编写, 所有权利保留。 欢迎转载,分享是进步的源泉。

转载请注明出处:http://chenhaoxiang.cn

本文源自人生之旅_谙忆的博客