HDOJ1020 Encoding - 谙忆-人生之旅

谙忆-人生之旅

学不止步,梦不停歇-陈浩翔

HDOJ1020 Encoding

 2015年09月07日

Problem Description
Given a string containing only ‘A’ - ‘Z’, we could encode it using the following method:

  1. Each sub-string containing k same characters should be encoded to “kX” where “X” is the only character in this sub-string.

  2. If the length of the sub-string is 1, ‘1’ should be ignored.


Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only ‘A’ - ‘Z’ and the length is less than 10000.

Output
For each test case, output the encoded string in a line.

Sample Input

1
2
3
4
5
6
7
8
2
ABC
ABBCCC
 

Sample Output
ABC
A2B3C

简单的字符串题目
需要注意的只有
如果输入:AABBBAAA
输出的是:2A3B3A
而不是:5A3B

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{
    int s,i,j,n,p,m;
    char a[100000],temp;
    scanf("%d",&s);
    while(s--)
    {
        scanf("%s",a);
        n=strlen(a);
        temp=a[0];
        m=1;
        for(i=1;i<=n;i++)
        {
            p=1;
            if(a[i]==temp)
            {
                m++;
            }
            if(a[i]!=temp)
            {
                p=0;
                temp=a[i];
            }
            if(p==0)
            {
                if(m==1)
                    printf("%c",a[i-1]);
                else
                    printf("%d%c",m,a[i-1]);
                m=1;
            }
        }
        printf("\n");
    }
            return 0;
}

本文章由[谙忆]编写, 所有权利保留。 欢迎转载,分享是进步的源泉。

转载请注明出处:http://chenhaoxiang.cn

本文源自人生之旅_谙忆的博客

 2015年09月07日 acm-c

« [C++]C++栈和队列 malloc函数详解 »